Instalar ie4Linux en Ubuntu

Bueno, imagino que este post le interesará únicamente a diseñadores y programadores de aplicaciones web, ya que teniendo firefox no creo que nadie sienta deseos de usar el internet explorer.

Me vi obligado a instalarme esta versión de Micro$oft Internet Explorer cuando probando una aplicación web que en el trabajo, desde firefox, se veía perfecto, al probarlo en otros equipos desde explorer, comprobaba como Micro$oft se pasaba por el forro casi todos los temas de respeto de estándares en CSS.

La verdad, es una mierda internet explorer hasta para crear una aplicación, donde tienes que hacer casi una hoja de estilos para ie en exclusiva con truquillos y hacks.

Ya que muchas veces no nos quedará más remedio, podemos usar wine para depurar nuestra aplicación en internet explorer desde Ubuntu.

Pasos a seguir:

Actualiza e instala wine y cabextract:

$ sudo apt-get update
$ sudo apt-get install wine cabextract

Descarga e instala IEs4Linux

$ wget http://www.tatanka.com.br/ies4linux/downloads/ies4linux-latest.tar.gz
$ tar zxvf ies4linux-latest.tar.gz
$ cd ies4linux-*
$ ./ies4linux

salu2!

Anuncios

20 Responses to Instalar ie4Linux en Ubuntu

  1. Madieta dice:

    No sabía que esto existía! No creo que sólo interese por temas de diseño o programación, por ejemplo hace poco tuve que arrancar Win sólo porque una mierdipágina mal hecha que necesitaba consultar no funcionaba en Firefox. Cada vez hay menos páginas TAN mal hechas pero lamentablemente aún queda alguna!

  2. facundo dice:

    Bienvenido al horrible mundo del desarrollo web.

    Es increíble que los desarrolladores tengamos que estar hackeando nuestras webs para que funcionen con esa porquería llamada IE6.

    Más aún, cuando te encuentres con las incompatibilidades entre IE6 e IE7, verás lo que es duro de verdad…..

    Cualquier cosa, tienes mi mail…..

  3. bigwall dice:

    Gracias por el aporte. En el trabajo me acabo de pasar a Linux pero hay ciertas webs que únicamente funcionan en ie. Ahora ya no tengo que depender tanto del wXp virtual. Me viene genial.

  4. gabomac dice:

    pues al final me dio un error que decia que no se pudo descomprimir los archivos y no termino la instalación.
    Alguien sabe que puedo hacer para solucionarlo.
    saludos

  5. Juampa dice:

    La pagina para mandar mensajitos a celular de Personal (Arg) no me recibe las respuestas, ni en firefox ni opera 😦 Este ie4linux viene al pelo!

    Gracias!

  6. Wartin dice:

    en *ubuntu se necesita también pygtk:

    sudo apt-get install python-gtk2

    Saludos!

  7. Isaac flores dice:

    tengo problemas al instalar ie4linux…realiza todo el procedimeinto pero no aparece nada al final…lo busque y nada….

  8. thebarx dice:

    Claro, es sencilla la solución:

    Veran, por alguna extraña razón se corta, pero hay que intentar varias veces, tantas como sea posible el ultimo paso. Cuando lo vuelves a correr, se queda donde se detuvo. Al final si se puede yo lo logre instalar. La carpeta se crea en tu usuario en /bin y el dispador, el icono o como se llame esta en la carpeta de Desktop (cuando finalize la instalación claro esta), porque toda la programación esta en ingles. Igual y bueno, no se que tan util sea tener el Internet Explorer cuando hay tan buenos navegadores web, seria interesante esuchar sus excusas xD.

  9. joan ventura dice:

    Al parecer el servidor no es muy bueno, hay ke mantenerse intentando hasta que baje todos los paquetes.

  10. Carlos Cala dice:

    Hola,

    Tengo un problema. Intenté instalar el ie4linux en mi Ubuntu-8.10-desktop-amd64. Ya instalé Wine (versión 1.0.1) y verifiqué en Synaptic que si tengo la librería cabextract. Pero priemero me aparece lo siguiente al intental instalarlo:

    IEs4Linux esta pensado para ser usado con versiones recientes de Wine (0.9.x). Parece que esta usando una versión antigua (wine-1.0.1). Es recomendable que actualice a la ultima versión de Wine (Vaya a: winehq.com).

    Sin embargo continúo con la instalación, pero termina (fallidamente) con:

    ui/pygtk/python-gtk.sh: line 6: 7333 Fallo de segmentación python “$IES4LINUX”/ui/pygtk/ies4linux-gtk.py

    ¿Alguien me puede ayudar por favor para solucionar este problema?

    Gracias

  11. Aplastacalabazas dice:

    Holas,
    Acabo de instalarlo en mi Linuxmint 5 con escritorio XFCE (Aclaro por si acaso), es OS está basado en Ubuntu y luego de varios intentos lo pude instalar para ello cuando ves el menu pincha en Avanzado y marca la opion que instale la version 7 del inefable IE. En mi caso me termino la instalacion del 6 y de la 7.

    Nos leemos.

  12. sergio dice:

    Por desgracia y por mucho que nos pese, en condiciones normales, son DEMASIADAS las veces que tenemos que recurrir al iexplorer de windows, por ejemplo, la compatibilidad de serie del firefox con el pdf es de lo peor que me han tirado a la cara, ¿Habéis intentado renovar la tarjeta del paro (tan de moda en los tiempos que corre) desde el firefox? ¿Y rellenar un formulario en línea? Ya os digo, si no eres un usuario avanzado, hay bastantes ocasiones en las que tienes que recurrir al iexplorer. Esperemos pase pronto a la historia y lo recordemos como una pesadilla.

    Un abrazo a todos
    Sergio

  13. Rafael Uribe Morfín dice:

    Buena entrada!.

  14. Muhas gracias dice:

    Hace muy poco que me he pasado a Linux. Uno de los problemas que tenía en el trabajo es que dependo de una página web que solo trabaja con ie6. Ni con la versión 7 de ese navegador puedo acceder, ya no digo nada de con otros navegadores. La opción que se trata en este post abre un montón de posibilidades ya que podré limitar su uso a la P—A M—-A de la página en cuestión.
    Muchas gracias y hasta la próxima

  15. pamchi dice:

    no funciono, se trabo el instalador, ya probe varias veces…

  16. yo necesite buscar una pc con win porque un pagina de la SEP aqui en mexico no funcionaba con firefox ni opera ni ninguno de esos no manches

  17. pamchi dice:

    Al final fue mas fácil correr una máquina virtual en “virtual box” porque no logre hacer funcionar esto en mi 9.04.

    Saludos

  18. Samuel dice:

    wuuuaaaauu!!! me cambie hace muy poco a Ubuntu, y utilizo la distribucion 9.04 y tambien uno de mis problemas recurrentes era acceder a paginas que solo se abren con IE.
    Instale ie4linux y me funciono de maravilla!!! claro que baja de forma conciderable la velocidad de trabajo… pero eso no importa! solo lo nesecitaba para ingresar a paginas que funcionan con el IE.
    Muchisimas gracias nen!!
    Nos Leemos!

  19. revxfire dice:

    Gracias soluciono mi problema con los active x para visualizar las paginas de los DVR

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: